最新手機文章

Image credit:

Flash 10.1 Android beta版發表,要Android 2.2以上限定

Sagat.Y
2010 年 5 月 21 日, 早上 07:00
0 分享次數
分享
分享
Twitter 發表
line
電郵
儲存

在iPhone上看不到Adobe Flash沒關係,在這次新發表的Android 2.2(Froyo)就可以看到了,而且還是Flahs 10.1的版本,並且目前是Android 2.2版限定,適用於其他行動裝置的版本,則是會在今年六月發表。
如果要在Android手機上使用Adobe Flash 10.1,很抱歉,至少要Android 2.2以上的版本,目前在MarketPlace上已經可以看到。另外,Adobe也鼓勵手機OEM廠或ODM廠在出廠時就預載。不過,目前仍是在Public beta階段,所以還是有些網站還是無法成功在Flash10.1上運作,像這次發表會的Hulu.com(在美國頗受歡迎的高畫質影片頻道,美國各家電視台合作並放到網站上)就仍不能收看。

跳轉之後有一些主站編輯詢問Adobe CTO有關於Flash 10.1的訪談。


Gallery: Flash 10.1 for Android (press shots) | 6 Photos




Q:為何Android 2.1不能裝?

A:由於Flash 10.1需要的API在Android 2.2(Froyo)以上版本才有提供或支援,而Adobe在這次發表會之前也試著找過其他方案,可惜仍是無法解決,所以Android 2.1(Eclair)以前的版本就不支援了。

Q:在Android 2.2上跑Flash 10.1有什麼特殊的硬體需求?
A:CPU至少要300MHz以上,像ARM 11、Cortex A8、A9、Tegra與Intel Atom都可以支援。不過,我們是在安裝Android 2.2的硬體上測試,如果有更低階的裝置可以跑Android 2.2,或許我們硬體需求還會向下修正。

Q:那如果不是Android裝置跑Flash 10.1則有什麼需求?
A:如果不是Android或其他行動裝置,CPU至少要600MHz,記憶體至少要64MB以上,所以在智慧型手機反而變得比較簡單,在其他平台我們仍會努力跑Flash的硬體需求降低。

Q:為何有些網站不能用行動版的Flash Player運作?
A:其實不一定是技術的問題,若是該網站內容有版權爭議時,我們有可能會ban掉該網站。

Q:Flash Lite 4與Flash 10.1的比較?
A:Flash Lite主要是給更低階手機所使用,兩者皆支援ActionScript 3,最大的差異為Flash 10.1是真正基於桌上型電腦所撰寫的,而Flash Lite則是針對行動裝置所研發。